Results 1 to 6 of 6

Topic: T3PA Pro pedals not working with DriveHub

  1. #1
    Babyfaced Assassin

    User Info Menu

    Question T3PA Pro pedals not working with DriveHub

    Hi,
    I bought a DriveHub a week ago. I also bought a T3PA Pro pedal set,
    T.RJ12 USB Adapter Adapter from Thrustmaster and a TH8A Shifter from Thrustmaster. I have a Logitech G29 wheel. I cant get the pedals to work through DriveHub. I tried to connect it via adapter to the usb hub and straight to the DriveHub. Still no response. Im trying to get it to cooperate with Xbox One S and PS4 Pro. Should i download any drivers for it or anything ?

  2. #2
    Senior Staff

    User Info Menu

    Re: T3PA Pro pedals not working with DriveHub

    that setup should work.... the t-rj12 driver was added after release, please make sure your f/w up to date

  3. #3
    Babyfaced Assassin

    User Info Menu

    Re: T3PA Pro pedals not working with DriveHub

    Quote Originally Posted by Podger View Post
    that setup should work.... the t-rj12 driver was added after release, please make sure your f/w up to date
    Sorry... Whats f/w ?

  4. #4
    Altar Desecrater

    User Info Menu

    Re: T3PA Pro pedals not working with DriveHub

    Quote Originally Posted by GajduSKc View Post
    Sorry... Whats f/w ?
    F/W = FirmWare

  5. #5
    Senior Staff

    User Info Menu

    Re: T3PA Pro pedals not working with DriveHub

    https://youtu.be/lXf4dL3SJzc
    have a look at this, should get you there

  6. #6
    Senior Staff

    User Info Menu

    Re: T3PA Pro pedals not working with DriveHub

    hi
    i got your PM but I'll answer here in case it helps others..

    so you want to use the TM pedals with the G29. I'm going to approach this from a different angle but end up in the same place. My first 2 TM wheels on came with as 2 pedal set, so I made and adapter to use the G27/G29 pedals with the TM wheels. TM use an odd ball rj12 jack, the retention tag is offset.

    so I lopped off about 15 centimeters of the TM pedal lead. I then soldered a D-sub 9 female to the piece of the lead with the RJ12, hey presto the G27 pedals connect to the T150... You even get all 3 pedals....

    Attachment 5341

    the consequence of this is my TM pedals now had a wire with no connector... So I soldered on a male d-sub 9 to mate with the photo above essentially fixing the cut, the other consequence is that my TM pedals were now basically g27/g29 ready...

    the wire color might vary, I only ever made on adapter
    1 - gnd - red
    2 - gas - yellow
    3 - brake - blue
    4 - clutch - green
    5 -
    6 - presence - white
    7 -
    8 -
    9 - power - brown ( 3.3V )

    for reference here is some mouser links to the connectors:

    https://www.mouser.ie/ProductDetail/...JK1tjFl1%2fhvs

    https://www.mouser.ie/ProductDetail/...YRJIqQ4kYok1mM

    - - - Updated - - -

    so if you want to swap gas and clutch you can simply swap the green and yellow wire

Similar Topics

  1. [PS4] Fanatec wheel + pedals + plus different shifter with drivehub
    By coolwhip27 in forum Fanatec Racing Wheels Support
    Replies: 3
    Last Post: 19th June 18, 15:34
  2. [GT SPORT] Drivehub + GTsport + Fanatec Pedals V3
    By mao996 in forum DriveHub Hardware Support
    Replies: 0
    Last Post: 5th April 18, 07:33
  3. Thrustmaster TX and T3PA on PS4 -- Pedals Not Functioning Properly
    By Newgun66 in forum Thrustmaster Racing Wheels Support
    Replies: 4
    Last Post: 16th March 18, 15:28
  4. [XBOX ONE S] Thrustmaster T300RS + T3PA Pro Pedals - Clutch Pedal not responding in Forza 7
    By warpedsoul in forum Thrustmaster Racing Wheels Support
    Replies: 3
    Last Post: 28th November 17, 23:04
  5. [Resolved] G29 Pedals not working as they should
    By Mantigor in forum Logitech Racing Wheels Support
    Replies: 2
    Last Post: 28th October 17, 15:32

Posting Permissions

  • You may not post new topics
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •