Hi Admins and other users,

So I received my drivehub 2 days ago. (UK buyer) Having read all the reviews was excited about it, as I had an old Logitech Force GT wheel, still brand new in the box and a copy of GT Sport I was keen to use it on.

2 days later and I haven't been able to get it to work at all. I've followed the manual instructions to the letter. Also looked at all the Youtube videos and still no luck. It's not as plug and play as advertised it seems.

I tried plugging the wheel usb into the controller port on the drivehub instead of the wheel port and I did get a calibration turn on the wheel, but my hope was short lived, as I get no response from the wheel at all when pressing the PS button, or any other button.

I figured that maybe it was a firmware issue, so I downloaded the firmware app for Mac and ran it, but lo and behold I'm getting a device not found message.

Please can someone help me, I don't want to give up on this just yet. I'd feel really stupid for having paid over $99 plus UK taxes for a brick, or have to send it back.

I'm not sure what I'm missing here.